最新版のAndroid対応のためにUnityのアプリをUnity5.6でリビルド⇒ParticleSystemのエミッタにバグでリリースできず・・・

Unityで作成した個人アプリを、Unity5.6対応とUnityAds2.1対応のためにアップデートしてみたところ、細かな仕様の変更点やらバグがあって土日の休日が潰れてしまった。。。

解決できなかった不具合は下記のエラー。

Sub-emitters must be children of the system that spawns them

 

 

 

 

根本的な問題は下記の投稿と同じだったのだけど、

Parenting of particle sub emitter in 5.6
https://forum.unity3d.com/threads/parenting-of-particle-sub-emitter-in-5-6.462180/

肝心の修正パッチがまだリリースされていないようだった。。。

richardkettlewell said:
This issue is fixed in the upcoming 5.6.0p4 patch.

 

hidenori

Web、モバイル関連、コンシューマゲーム、モバイルコンテンツ等、 コンテンツ全般の開発や制作、コンテンツのバックエンドになる技術等を扱っています。 開発系 .net / mono、Java, javascript, c++, c, Perl, PHP, phython, インフラはAWSとLinux仮想化で自前構築 ・経歴 ⇒外資|ゲーム開発|ローカライズ|SE|QA|PD|PG|SE|大学 ⇒Web|SE|ベンチャー|コンテンツ|音楽⇒外資|ケータイ|ゲーム ⇒Web|SE|ベンチャー|音楽|大学院|ケータイコンテンツ|スマートフォンコンテンツ|独自コンテンツ配信 いろいろやってます

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です